Call Queue RoutingFully Operational

Components

Call Routing & Policies

Locations

EMEA



March 26, 2025 8:12AM GMT
[Investigating] We are currently investigating an issue affecting a small subset of customers, where call queue calls are not being routed to agents as expected. Our technical team is working diligently to resolve the issue. We will update our status page with further details as our investigation progresses.

March 26, 2025 9:37AM GMT
[Monitoring] Our technical teams have implemented the necessary measures to restore service, and the issue affecting call queues has been resolved. We recommend that affected users log out of their Webphones and Salesforce, then log back in. Inbound calls should now route as expected. We will continue to monitor the platform closely and provide further updates.

March 26, 2025 10:23AM GMT
[Resolved] Following a period of close monitoring, we have confirmed there have been no further occurrences of the issue, and the Natterbox platform is fully operational. The incident is now closed. We apologise for any inconvenience this may have caused. Please contact our Customer Support Team if you experience any further issues.

Back to current status