Call Connectivity and Wallboard IssuesFully Operational

Components

Natterbox CTI, Natterbox Wallboards

Locations

APAC, EMEA, North America, Wallboards v2 (Flightdeck)



September 23, 2024 3:39PM BST
[Monitoring] We are aware of the recent call connectivity and wallboard issues. Our technical team has successfully implemented a solution that has resolved these problems. Our Technical team will continue monitoring the platform closely. Please contact our Customer Support Team if you experience any further issues.

September 23, 2024 4:41PM BST
[Resolved] Following a period of close monitoring, we can confirm that the service has been fully restored, as communicated in our previous update. The Natterbox platform is fully operational, and this incident has now been closed. We apologise for any inconvenience this may have caused. Should you encounter any further issues, please contact our Customer Support Team.

Back to current status