APAC, EMEA, North America
July 2, 2024 8:46PM BST
[Investigating] We are aware of issues affecting a subset of customers relating to the inability for call queue calls to be routed to agents.
July 2, 2024 9:47PM BST
[Monitoring] We've identified the cause of the issue and have resolved the issue with call queues. We're currently monitoring all systems.
July 3, 2024 9:35AM BST
[Resolved] Following a period of close monitoring, we have confirmed there have been no further occurrences of the issue.
The Natterbox platform is fully operational and the incident is now closed.
We apologise for any inconvenience this may have caused.
Please contact our Customer Support Team if you experience any further issues.